EverQuest II: Chains of Eternity is now Live!

Written by Feldon on . Posted in Expansion News

Holly “Windstalker” Longdale just tweeted:

Trackback from your site.

Comments (13)

  • MindNumb

    |

    Except Naggy lol

    Reply

  • Kryvak

    |

    Everfrost just crashed, my toon on Guk is still up though.

    Reply

  • Tbiggs

    |

    yeah. Everfrost is poof. Though freeport is still up.

    Reply

  • Kryvak

    |

    Now it’s showing all my toons on EF (was showing 3 before) and says locked instead of down.

    Reply

  • Kryvak

    |

    EF is back up.

    Reply

  • ziplock

    |

    Freeport is a disaster to log on to.

    Reply

  • Charn

    |

    I’m just wondering when the forums are going to be up . . . . or is it just me? Still saying, “Under maintenance” when clicking Forums button from the EQ2 website.

    Reply

    • Feldon

      |

      I’m just wondering when the forums are going to be up . . . . or is it just me? Still saying, “Under maintenance” when clicking Forums button from the EQ2 website.

      Are you going to http://forums.station.sony.com/eq2/index.php ?

      Reply

  • Lempo of Everfrost

    |

    I’m 95 (adventure level) and still had 20 min left on 2hr potion. Didn’t even use 85% vitality.
    This was in Contested Kael Warlock tanking with 3 healers.

    Reply

  • din

    |

    Any secrets for getting to L95 so quickly ? I’ve got a few l92 TS alts that I would like to max out, so i hope we have a few ts quest lines. Grinding 3 levels of rush orders isn’t my idea of fun

    Reply

  • Brigh.Guk

    |

    Man .. the pally werewolf merc is worthless. 8( I think I am gonna switch back to my DE shadowknight.

    Reply

  • Brigh.Guk

    |

    Feldon,

    I just clicked on your link and still got the maintenance screen. 8(

    Reply

    • Feldon

      |

      Feldon,

      I just clicked on your link and still got the maintenance screen. 8(

      When someone gets the Maintenance screen, and the forums are actually up and running, this indicates that their IP may be blocked due to very high traffic. I ran into this with my EQ2 Forum Scraper. Perhaps someone else else on your ISP was spam-clicking the forum or something?

      Reply

Leave a comment

- Name (required)
- Website (optional)
Please post your comments without flaming or insulting other players or personally attacking SOE employees. Comments from bogus e-mail addresses may be deleted. If you wish to have an Avatar picture, feel free to create an account on Gravatar.com. Once you sign up for a Gravatar account, then any Wordpress-powered blog you comment on will automagically show your avatar.

Powered by Warp Theme Framework